System.Diagnostics.Debug 4.0.11-rc2-24027

Provides classes and attributes that allows basic interaction with a debugger. Commonly Used Types: System.Diagnostics.Debug System.Diagnostics.DebuggerStepThroughAttribute System.Diagnostics.Debugger System.Diagnostics.DebuggerDisplayAttribute System.Diagnostics.DebuggerBrowsableAttribute System.Diagnostics.DebuggerBrowsableState System.Diagnostics.DebuggerHiddenAttribute System.Diagnostics.DebuggerNonUserCodeAttribute System.Diagnostics.DebuggerTypeProxyAttribute \r\n TFS ID: 1599443, GitHub SHA: https://github.com/dotnet/corefx/tree/eede273a4dfabcea608621f5e1bbf8ad00584cfb

Showing the top 20 packages that depend on System.Diagnostics.Debug.

Packages Downloads
NETStandard.Library
A set of standard .NET APIs that are prescribed to be used and supported together. 18a36291e48808fa7ef2d00a764ceb1ec95645a5 When using NuGet 3.x this package requires at least version 3.4.
470
NETStandard.Library
A set of standard .NET APIs that are prescribed to be used and supported together. This includes all of the APIs in the NETStandard.Platform package plus additional libraries that are core to .NET but built on top of NETStandard.Platform. When using NuGet 3.x this package requires at least version 3.4.
56
ncrontab.signed
NCrontab is crontab for all .NET runtimes supported by .NET Standard 1.0. It provides parsing and formatting of crontab expressions as well as calculation of occurrences of time based on a schedule expressed in the crontab format.
19
NuGet.Versioning
NuGet's implementation of Semantic Versioning.
17
xunit.core
Includes the libraries for writing unit tests with xUnit.net. Supported platforms: - Desktop .NET 4.5+ - .NET Core (Universal Windows Apps 10+, DNX Core 5+) - Windows 8 - Windows Phone 8 (Silverlight) - Universal (Windows Phone 8.1+, Windows 8.1+) - Xamarin (MonoTouch, MonoAndroid, Xamarin iOS Universal) - Portable Libraries (supporting Profile259)
17
Portable.BouncyCastle
Support for .NET 4, WP 8 SL, WP 8.1, Windows 8, MonoTouch, MonoAndroid, Xamarin.iOS, Core CLR IMPORTANT: The Serpent cipher as of 1.8.0 is incompatible with the behaviour of Serpent in earlier releases; it has been modified to conform to the standard byte-order interpretation for blocks (and keys). The previous behaviour is available from 1.8.0 as the "Tnepres" cipher. See BMA-52 for more information if this may affect you. Crypto features: - Generation and parsing of PKCS-12 files. - X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates. - PBE algorithms supported by PbeUtilities: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256. - Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withECDSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA. - Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, ChaCha, DES, DESede, GOST28147, HC-128, HC-256, IDEA, ISAAC, Noekeon, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Salsa20, SEED, Serpent, Skipjack, TEA/XTEA, Threefish, Tnepres, Twofish, VMPC and XSalsa20. - Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR). - Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS-5/7, TBC, X.923, and Zero Byte. - Asymmetric key algorithms: ElGamal, DSA, ECDSA, NaccacheStern and RSA (with blinding). - Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS-1. - AEAD block cipher modes: CCM, EAX, GCM and OCB. - Digests: GOST3411, Keccak, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, SHA3, Tiger, and Whirlpool. - XOFs: SHAKE. - Signer mechanisms: DSA, ECDSA, ECGOST3410, ECNR, GOST3410, ISO9796d2, PSS, RSA, X9.31-1998. - Key Agreement: Diffie-Hellman, EC-DH, EC-MQV, J-PAKE, SRP-6a. - Macs: CBCBlockCipher, CFBBlockCipher, CMAC, GMAC, GOST28147, HMac, ISO9797 Alg. 3, Poly1305, SipHash, SkeinMac, VMPCMAC. - PBE generators: PKCS-12, and PKCS-5 - schemes 1 and 2. - OpenPGP (RFC 4880) - Cryptographic Message Syntax (CMS, RFC 3852), including streaming API. - Online Certificate Status Protocol (OCSP, RFC 2560). - Time Stamp Protocol (TSP, RFC 3161). - TLS/DTLS client/server up to version 1.2, with support for the most common ciphersuites and extensions, and many less common ones. Non-blocking API available. - Elliptic Curve Cryptography: support for generic F2m and Fp curves, high-performance custom implementations for many standardized curves. - Reading/writing of PEM files, including RSA and DSA keys, with a variety of encryptions. - PKIX certificate path validation
17
ConcurrentHashSet
A thread-safe hash-based set
17
NCrontab.Signed
NCrontab is crontab for all .NET runtimes supported by .NET Standard 1.0. It provides parsing and formatting of crontab expressions as well as calculation of occurrences of time based on a schedule expressed in the crontab format.
17
WindowsAzure.Storage
This client library enables working with the Microsoft Azure storage services which include the blob and file service for storing binary and text data, the table service for storing structured non-relational data, and the queue service for storing messages that may be accessed by a client. For this release see notes - https://github.com/Azure/azure-storage-net/blob/master/README.md and https://github.com/Azure/azure-storage-net/blob/master/changelog.txt Microsoft Azure Storage team's blog - http://blogs.msdn.com/b/windowsazurestorage/
17
NuGet.Configuration
NuGet's client configuration settings implementation.
16
Polly
Polly is a .NET 3.5 / 4.0 / 4.5 / PCL library (Profile 259) that allows developers to express transient exception handling policies such as Retry, Retry Forever, Wait and Retry or Circuit Breaker in a fluent manner.
16
Polly-Signed
Polly is a .NET 4.0 / 4.5 / PCL library (Profile 259) / .NET Standard 1.0 library that allows developers to express resilience and transient fault handling policies such as Retry, Circuit Breaker, Timeout, Bulkhead Isolation and Fallback in a fluent and thread-safe manner.
16
Polly-Signed
Polly is a .NET 3.5 / 4.0 / 4.5 / PCL library (Profile 259) that allows developers to express transient exception handling policies such as Retry, Retry Forever, Wait and Retry or Circuit Breaker in a fluent manner.
16
Polly-Signed
Polly is a .NET 3.5 / 4.0 / 4.5 / PCL (Profile 259) / NET Standard 1.0 library that allows developers to express transient exception and fault handling policies such as Retry, Retry Forever, Wait and Retry or Circuit Breaker in a fluent manner.
16
NuGet.Versioning
NuGet's implementation of Semantic Versioning.
16

MonoAndroid 1.0

  • No dependencies.

MonoTouch 1.0

  • No dependencies.

.NET Framework 4.5

  • No dependencies.

.NETCore 5.0

.NET Standard 1.0

.NET Standard 1.3

.NETPortable 0.0

  • No dependencies.

Windows 8.0

  • No dependencies.

WindowsPhone 8.0

  • No dependencies.

WindowsPhoneApp 8.1

  • No dependencies.

Xamarin.iOS 1.0

  • No dependencies.

Xamarin.Mac 2.0

  • No dependencies.

Xamarin.TVOS 1.0

  • No dependencies.

Xamarin.WatchOS 1.0

  • No dependencies.

Version Downloads Last updated
4.3.0 10 04/27/2026
4.3.0-preview1-24530-04 10 04/29/2026
4.0.11 9 04/28/2026
4.0.11-rc2-24027 8 04/29/2026
4.0.11-beta-23516 8 04/28/2026
4.0.11-beta-23409 8 04/28/2026
4.0.11-beta-23225 9 04/28/2026
4.0.10 9 04/28/2026
4.0.10-beta-23109 9 04/28/2026
4.0.10-beta-23019 8 04/28/2026
4.0.10-beta-22816 5 05/13/2026
4.0.10-beta-22605 8 04/28/2026
4.0.10-beta-22416 10 04/28/2026
4.0.10-beta-22231 10 04/28/2026
4.0.0 10 04/27/2026
4.0.0-beta-23109 9 04/28/2026
4.0.0-beta-23019 9 04/28/2026